Need a little help getting started


#1

Am new here and reading the doc’s am currently left wondering how it works and which version of python it supports… Am on mac os x and did the homebrew install method . My current system is python 3 and guessing Mitmproxy is for 2.7? I use charles alot in my daily … though this tool seems like overall would be a better tool to use moving forward . Can any one help me getting the tool started via cli and would be cool to play with beta web version too …

thank you all for your time in advance.


#2

Hi,

We’re Python 3.5+ only for a while, and will soon require Python 3.6. You can see this in mitmproxy’s help screen for example.