Installing mitmproxy with pip, having error

If I install it through pip, I obtain this error.
Traceback (most recent call last):
File “/usr/local/bin/mitmproxy”, line 7, in
from mitmproxy.main import mitmproxy
File “/Library/Python/2.7/site-packages/mitmproxy/”, line 5, in
from six.moves import _thread # PY3: We only need _thread.error, which is an alias of RuntimeError in 3.3+
If I install it through brew:
==> Auto-updated Homebrew!
Updated 1 tap (homebrew/core).
No changes to formulae.
Warning: mitmproxy-0.17.1 already installed, it’s just not linked

MAybe I’ve already installed, but I can’t see the HTTP codes of my Android.
I am totally new in this…please help!!!


It does look like you have mitm already installed, but can you please post the entire traceback, because from this, it isn’t exactly clear what the issue is.

From your Homebrew output it looks like you should try running: brew link mitmproxy and then run mitmproxy

Thank you very much! Now it works: I just linked it…I am reaaaally new in all this.
Can you help me on how I should do to sniff my Android device with mitmproxy?
I’ve already installed the mitmproxy certificate on the Android, I’ve rooted it, changed the gateway …
but I can’t see nothing on the mitmproxy terminal.
Could you help me??
Thanks in advance!

I’m glad that worked. Now for further debugging, you’ll have to provide the information in a clear manner.

Which OS are you running this on?

How are you running it (the exact command)?

Is there some online guide whose steps you’re following?

Don’t start with Android. First, try testing things on your OS itself. Run mitmproxy & then pass your browsers traffic through it. See if that works. etc.


I’m running OSX 10.11.2 EL CAPITAN
I run the mitmproxy terminal with this command:
mitmproxy -T --host

I am following these guides:
how to sniff the whatsapp pwd
how to use mitmproxy to read HTTP traffic

I have also found this about the mitmproxy and OSx : (

Thank you very much!!