Couple observations

This is using 3.0.4.

  1. Setting --listen-host -p 8889 seems to still use all interfaces: Proxy server listening at http://*:8889

  2. Using the *=cert option and pointing it to the mitmproxy-ca.pem fails to work with untrusted in the browser, but leaving off the option and everything works well.

That’s it…thank you for a great app.

Thanks for the feedback.

  1. listen_host expects an argument.
  2. Take a look at --cert expects a leaf certificate, not a CA.

Thank you…correction, I do have a host in the --listen-host -p 8889. And thank you I will look at the --cert option.

LOL…looks like the forum is reformatting my posts :wink: my command is --listen-host IP -p 8889.