Issues with --ssl-ignore


#1

Dear all,

I am trying to use mitmproxy as a reverse proxy to forward requests from a machine to a target. Unfortunately the client I initiate the request from is not able to establish the connection.

In the mitmproxy Eventlog I do always receive the error that there is a certificate verification error for the target machine because it is using a selfsigned certificate. I should use the option --ignore.

When trying to pass --ignore I am notified to use --ssl-ignore instead, which doesn’t seem to work though.

I’ve also tried to pass the ssl_verify_upstream_trusted_ca but I wasn’t able to get this to work either.

Can anyone please point me into the right direction?

Thank you very much.


#2

have you tried with --ssl-insecure? (from options)