Server_replay_ignore_params usage


#1

Hi,

I’m trying to exclude some of the request query params from the server replay request matching by utilizing server_replay_ignore_params option:

mitmproxy --server-replay previously-saved-flows --server-replay-kill-ext --set server_replay_ignore_params=App

With the above, I can see “App” as a value for server_replay_ignore_params under options view in cmd interface. But my previously recorded response with “App=a1” does not replay for a request with “App=a2”. Can’t quite figure out why. I wonder if someone can help with this.

And 1 more question that I’ve got is how to specify multiple query params to ignore during the replay? Specifying multiple “–set server_replay_ignore_params=value” params keeps only the latest value…


#2

Ran mitmproxy from source and performed some more digging. It turns out that “–set server_replay_ignore_params=App” is not picked when set this way. It does show up in the Options view but in runtime, “ctx.options.server_replay_ignore_params” is empty. I had to manually edit “server_replay_ignore_params” value in the Options view and only after that “ctx.options.server_replay_ignore_params” started properly reflecting the value I set.

It looks like a defect to me. Thoughts?