ModuleNotFoundError: No module named 'libmproxy' in latest master release


#1

Finally got the latest master release installed in Kali, but when trying to run it I receive this error.

What can i do to fix it?


#2

Also, to explain what i want to do:

I want to turn my laptop into a hotspot and run mitmproxy on it, so that all devices that connect to it will have my script injected to every webpage they visit (it’s a mining script). So, in exchange for the free WiFi I can earn some revenue. It is fully exposed that this will happen. Is the line I’m using to run mitmproxy in the snapshot above correct for this? Will this work as I intended it? Right now after I run the command and try to connect to the hotspot I cant get internet connection from it. I made sure to turn port forwarding on with

sysctl -w net.ipv4.ip_forward=1
Then I run
iptables -t nat -A PREROUTING -i wlan0 -p tcp --dport 80 -j REDIRECT --to-port 8080
iptables -t nat -A PREROUTING -i wlan0 -p tcp --dport 443 -j REDIRECT --to-port 8080
Then I run the mitmproxy command as shown in the screenshot

What am I doing wrong?