Mitproxy as HTTPS Proxy


#1

I’m using mitmproxy to intercept traffic, HTTP Traffic is being intercepted but HTTPS traffic is not being intercepted for some reason (?)

Using the default config with the command

mitmweb
Web server listening at http://127.0.0.1:8081/
Proxy server listening at http://*:8080

How can I set a config for a HTTPS proxy?


#2

If you have installed mitmproxy’s certificate it should work out of the box. If it’s not, write something more about your use case (proxy set in global OS setting? or in-app settings).