Mitmproxy/dump/web not fowarding upstream traffic to burp


#1

Hello all, I’m having massive problems trying to create an upstream proxy to Burp. I have the following set up:

  1. Latest mitmproxy download (3.0.4) and latest Burp Pro (1.7.33) download.
  2. Both mitmproxy and Burp certificates installed to use SSL.
  3. Burp settings:
  • Listening on all interfaces on port 8080
  • Invisible proxying enabled
  • Intercept Server Responses: Or|Request| was Intercepted
  1. Firefox set to listen on Port 9090

I then run the command:
mitmdump --listen-port 9090 --upstream="http://My_Ip_Addr:8080"

I can hit HTTPS sites, but no matter what I do the requests don’t show up in my burp log. I also tried disabling SSL certificate checks using the --set insecure_ssl=true option.

I think this is a problem with MITM as when I change my proxy in Firefox to use port 8080 requests show up as normal. Any advice?


#2

Hi,

There’s no --upstream option in mitmproxy. You want --mode upstream:localhost:8080.


#3

OMG you are a legend!!! I was trying to troubleshoot this forever. I’m getting 502 bad gateway errors due to certificate validation problems. Do I always have to specify --set insecure_ssl=true or is there a way around that?


#4

You can also specify it in ~/.mitmproxy/config.yaml or set the ssl_verify_upstream_trusted_ca option. :slight_smile: