Cookies disabled, for Google account


I noticed something, when playing with MITMproxy.
When I want to connect to my gmail account (of course, through MITMproxy), I get the following error:
“Oops! Your browser seems to have cookies disabed”…

Does anyone know why? Also, is there any way to fix this?

(of course, cookies are enabled on my Firefox browser. I only get this error msg when connecting through mitmproxy)


Tux :confused:

No clues?

Has this ever happened to anyone? Perhaps the answer is so obvious, I should already be aware of it?
Or maybe this could be a bug?

Bumpy-dump bump bump!

Nobody has a hint for me?
It’s weird because… I can connect to hotmail without any problem, but not on gmail.
What’s going on?

It happened to me as well.

Which mitmproxy version are you guys on?

Works just fine for me:

I’m on 0.17 here.
I got this problem on though.
I guess it’s pretty much the same as connecting directly to the account?

EDIT: Yes indeed, it’s exactly the same: “”.
I tried once again, and same error.

Maximilian are you on 0.17 or 0.18? Or maybe 0.25 in your case, since you may have a dev version :wink:

I’m on 0.18/master, which works fine. I can reproduce it on 0.17 though, but it seems to be fixed already.

I’m using the version given on Docker here:

But I guess it’s still 0.17?

Well, it wasn’t very clear if the DEV version available here:
would be 0.18 or not.

But it shows that it has been updated like 10 hours ago, so I took a chance to pull the latest DEV version from the repository, and run:
mitmproxy --version

The result is:
mitmproxy 0.18

Great! Now I was able to try again, with gmail, and guess what?
It works! The problem is officially fixed, since 0.18.

Thanks Maximilian! :slight_smile:

Yes, and happen to me as well. Happening for Chrome, Firefox in Windows, Ubuntu, Android, but not happend in Dolphin, Opera Mini on Android.