Tilde (~) not triggering filter (Solved)


#1

Hello, community.

I’m new to mitmproxy. So, I’m sorry if this is a silly question, but I couldn’t find solution in other topics.

So, I thought my problem was with international keyboard setup. Although, I now have a US keyboard and the problem persists. I want to filter flows from mitmproxy main screen. Then I hit (~) then (u) but nothing shows up for me to type the regex…

If I try to type:

~u google.com

I’ll eventually be send to the “options” page when I type the first “o” of google.
Am I doing something wrong?

Thanks for any help!


Solved
Ok, fellows. I misunderstood the concept. Instead of selecting a specific host, what we do is ignore a specific pattern. And to do this we click “o”, then “I”, then we type the regex ignore pattern.

Thanks anyway! :slight_smile: