Not all config options applied via ~/.mitmproxy/mitmproxy.conf


#1

Hello,

I’ve noticed after updating to mitmproxy 1.0.2, that the config format is now a yaml file as per…

http://docs.mitmproxy.org/en/stable/config.html

I’ve looked at the options.py source file to convert my options, but noticed that not all options works…

---
listen_port: 8282
anticache: true
http2: false
tcp_hosts:
- slack-msgs.com
no_mouse: true

For the above, listen_port and tcp_hosts seem to work without issue, but anticache and no_mouse settings don’t work at all. I suspect that I’ve fouled up my boolean options somehow.

Besides providing them on the command line, I’m wondering what the actual settings would be in the config to get this working.


#2

Thanks for reporting this. I think you’re hitting the same issue as in https://github.com/mitmproxy/mitmproxy/issues/1899?