Installation problems on Mint 17.3


#1

I try to install mitmproxy but something wrong and I can’t solve it

> sudo apt-get install python3-pip python3-dev libffi-dev libssl-dev libtiff5-dev libjpeg8-dev zlib1g-dev libwebp-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libjpeg8-dev is already the newest version.
python3-dev is already the newest version.
zlib1g-dev is already the newest version.
libffi-dev is already the newest version.
libssl-dev is already the newest version.
libtiff5-dev is already the newest version.
python3-pip is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libwebp-dev : Depends: libwebp5 (= 0.4.0-4) but 0.4.3-1.3 is to be installed
E: Unable to correct problems, you have held broken packages.

> sudo pip3 install mitmproxy
The directory '/home/quazinode/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/quazinode/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Collecting mitmproxy
  Downloading mitmproxy-1.0.2-py3-none-any.whl (1.4MB)
    100% |████████████████████████████████| 1.4MB 667kB/s 
Collecting Flask<0.12,>=0.10.1 (from mitmproxy)
  Downloading Flask-0.11.1-py2.py3-none-any.whl (80kB)
    100% |████████████████████████████████| 81kB 4.3MB/s 
Collecting click<7,>=6.2 (from mitmproxy)
  Downloading click-6.7-py2.py3-none-any.whl (71kB)
    100% |████████████████████████████████| 71kB 3.8MB/s 
Collecting jsbeautifier<1.7,>=1.6.3 (from mitmproxy)
  Downloading jsbeautifier-1.6.4.tar.gz (51kB)
    100% |████████████████████████████████| 51kB 4.3MB/s 
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-build-018jh5up/jsbeautifier/setup.py", line 38, in <module>
        cmdclass = {'test': PyTest},
      File "/usr/lib/python3.4/distutils/core.py", line 108, in setup
        _setup_distribution = dist = klass(attrs)
      File "/usr/local/lib/python3.4/dist-packages/setuptools/dist.py", line 320, in __init__
        _Distribution.__init__(self, attrs)
      File "/usr/lib/python3.4/distutils/dist.py", line 280, in __init__
        self.finalize_options()
      File "/usr/local/lib/python3.4/dist-packages/setuptools/dist.py", line 386, in finalize_options
        ep.require(installer=self.fetch_build_egg)
      File "/usr/local/lib/python3.4/dist-packages/pkg_resources/__init__.py", line 2318, in require
        items = working_set.resolve(reqs, env, installer, extras=self.extras)
      File "/usr/local/lib/python3.4/dist-packages/pkg_resources/__init__.py", line 859, in resolve
        raise VersionConflict(dist, req).with_context(dependent_req)
    pkg_resources.VersionConflict: (six 1.5.2 (/usr/lib/python3/dist-packages), Requirement.parse('six>=1.10.0'))
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-018jh5up/jsbeautifier/

sudo -H pip3 install mitmproxy

Installing collected packages: pycparser, cffi, brotlipy, Pillow, typing, ruamel.yaml, sortedcontainers, idna, pyasn1, appdirs, pyparsing, packaging, setuptools, cryptography, pyOpenSSL, click, hyperframe, hpack, h2, backports-abc, tornado, cssutils, construct, certifi, pyperclip, passlib, PyYAML, argh, pathtools, watchdog, Werkzeug, itsdangerous, MarkupSafe, Jinja2, Flask, urwid, requests, editorconfig, jsbeautifier, html2text, blinker, mitmproxy
  Running setup.py install for pycparser ... done
  Found existing installation: Pillow 2.3.0
    Uninstalling Pillow-2.3.0:
      Successfully uninstalled Pillow-2.3.0
  Running setup.py install for typing ... done
  Found existing installation: setuptools 3.3
    Uninstalling setuptools-3.3:
      Successfully uninstalled setuptools-3.3
  Running setup.py install for cryptography ... error
    Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-4vprx7a6/cryptography/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-yr5c09bn-record/install-record.txt --single-version-externally-managed --compile:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-build-4vprx7a6/cryptography/setup.py", line 334, in <module>
        **keywords_with_side_effects(sys.argv)
      File "/usr/lib/python3.4/distutils/core.py", line 108, in setup
        _setup_distribution = dist = klass(attrs)
      File "/usr/local/lib/python3.4/dist-packages/setuptools/dist.py", line 320, in __init__
        _Distribution.__init__(self, attrs)
      File "/usr/lib/python3.4/distutils/dist.py", line 280, in __init__
        self.finalize_options()
      File "/usr/local/lib/python3.4/dist-packages/setuptools/dist.py", line 386, in finalize_options
        ep.require(installer=self.fetch_build_egg)
      File "/usr/local/lib/python3.4/dist-packages/pkg_resources/__init__.py", line 2318, in require
        items = working_set.resolve(reqs, env, installer, extras=self.extras)
      File "/usr/local/lib/python3.4/dist-packages/pkg_resources/__init__.py", line 859, in resolve
        raise VersionConflict(dist, req).with_context(dependent_req)
    pkg_resources.VersionConflict: (six 1.5.2 (/usr/lib/python3/dist-packages), Requirement.parse('six>=1.10.0'))
    
    ----------------------------------------
Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-4vprx7a6/cryptography/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-yr5c09bn-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-4vprx7a6/cryptography/

#2

We only support 3.5 and beyond. Have you tried our prebuilt binaries? http://docs.mitmproxy.org/en/stable/install.html#installation-on-linux