Errors configuring transparent proxy on Mac OS (It doesn't work!)

I’m trying to set up a transparent proxy on Mac OS to intercept secure websocket traffic on port 3001.
I can’t use a regular proxy as iOS doesn’t respect proxy settings for the websocket traffic

I have followed the docs here:

It doesn’t work, and I have identified two possible issues. I don’t know how to fix either of them.

Issue1. According to the instructions, editing the sudoers file will allow any user to run /sbin/pfctl -s state

however running this gives the error
pfctl: /dev/pf: Permission denied

Issue2. Possible error when running sudo pfctl -f pf.conf

pfctl: Use of -f option, could result in flushing of rules
present in the main ruleset added by the system at startup.
See /etc/pf.conf for further details.

No ALTQ support in kernel
ALTQ related functions disabled

I’m running on mac os 10.14.5, have also tried 10.13
Have confirmed that the sudoers file has been modified and have tried reboot

System information
Mitmproxy: 4.0.4
Python:    3.7.3
OpenSSL:   OpenSSL 1.0.2r  26 Feb 2019
Platform:  Darwin-18.6.0-x86_64-i386-64bit

any suggestions?

thank you