Upgrading python sdk

#1

Hi,
I’m using mitmdump 4.0.4 (windows) and I’m failing to use the datetime.fromtimestamp(0.0) which should return “00:00:00 Thursday, 1 January 1970”.
I found issue 29097 in python 3.6.x and solved in python 3.7 and later.
Issue was filed to mitmproxy github but this one was closed and I was redirected to here.

Except workaround the problem any planes for mitm upgrading python version?

Regards,
Kobi

0 Likes