How to force subject (alternative) name


#1

When I run mitmproxy in reverse mode I configure clients to connect to “https://localhost:12345/” instead of real server. It works well for SNI-speaking clients but doesn’t for clients which doesn’t support SNI. How can I set subject name to in the fake MitM certificate? Is the addon required or is there a command line option?